Page 1 of 1

(possible) bug report

Posted: Mon Jun 29, 2020 2:57 am
by TyRone
Good morning,

Last night I've been exploring the possibilities of CMJ further and ran into three possible issues:

1) I am using a SpaceMouse Pro Wireless and somehow CMJ does not recognizes the button presses.
In the 3DxWare configuration I've set all buttons to act like key input. But somehow i cannot get CMJ to detect the button input.
Not sure if this is a bug or a result of the 3DxWare config/program.
Workaround is to use the Key input and bind them directly in the target app.

2) When setting a target and enabling it the output is send to the target window only when CMJ is the selected window.
I tried this using a browser and discord and when either of these apps were the active window, the joystick output was not send to the selected target.
The key input i could not test due to issue 1.

3) Using the digital output option I've set the Tx/Ty/Tz axis of my SpaceMouse as a WASD controller (great feature btw!)
The Z axis is used as a Select/Back output. When configuring this i noticed the "A" key did not respond like expected. Tested this with a notepad like the instruction video. Tested this with different Key output and through manual input [A_DN] or selecting this through the menu.
Using a different key worked fine with the same axis and setting "A" to another axis gave the same result (The "A'" refused).
Did not test this with other keys then W,A,S,D,Q,E,SPACE,BACKSPACE

For reference, my target app is Elite Dangerous
OS: Windows10
Input devices: Thrustmaster Warthog, TFRP Pedals, SpaceMouse Pro Wireless
Apps: GameGlass, VoiceAttack, Joystick Gremling, CMJ, LEA Extended Input

Re: (possible) bug report

Posted: Sun Sep 13, 2020 2:03 pm
by DevRuss
My apologies for the late reply! It is odd that the spacemouse pro wireless button presses are not detected. I'll take a look at this for the next version.